Back to overview
Resolved

Users unable to register or log in

Jul 16, 2026 at 8:15am UTC
Affected services
Member Zone UI

Resolved
Jul 16, 2026 at 10:10am UTC

This incident is resolved. Our authentication provider mitigated the disruption caused by the upstream AWS outage, and login has been stable since. Thanks for your patience.

Updated
Jul 16, 2026 at 10:01am UTC

Our authentication provider has taken action to work around the underlying AWS issue, and login is now functioning again. We're monitoring closely to confirm stability before marking this resolved. If you had trouble logging in earlier, please retry.

Updated
Jul 16, 2026 at 8:27am UTC

We've identified the cause: our third-party authentication provider is impacted by an ongoing, widespread AWS outage. This is affecting the ability of users to register or log in. Because the root cause sits with AWS, resolution timing is largely dependent on their recovery. We're monitoring AWS status closely and will update this page as the situation develops.

Created
Jul 16, 2026 at 8:15am UTC

We're investigating reports of users being unable to log in or authenticate. Our authentication provider appears to be affected by a wider AWS incident.